Re: [PATCH 01/14] GFS: headers

From: viro
Date: Thu Sep 01 2005 - 09:31:05 EST


On Thu, Sep 01, 2005 at 04:19:34PM +0200, Arjan van de Ven wrote:
> > +/* Endian functions */
>
> ehhhh again why??
> Why is this a compiletime hack?
> Either you care about either-endian on disk, at which point it has to be
> a runtime thing, or you make the on disk layout fixed endian, at which
> point you really shouldn't abstract be16_to_cpu etc any further!

Well... I would disagree with the very end of it (e.g. having on-disk
block number representation declared as __bitwise, so that it wouldn't be
mixed with __be<n> + having coversion helpers consisting of
static inline u32 foo_to_cpu(foo n)
{
return be32_to_cpu((__force __be32)n);
}
etc. may be valid technics, assuming that these objects were passed around
enough to deserve it.

Blanket "let's rename for the sake of renaming" is a BS, of course...
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/