Re: [PATCH] cpuset semaphore depth check deadlock fix

From: Linus Torvalds
Date: Fri Sep 09 2005 - 17:16:50 EST




On Fri, 9 Sep 2005, Paul Jackson wrote:
>
> This patch fixes this deadlock by wrapping the up() and down()
> calls on cpuset_sem in kernel/cpuset.c with code that tracks
> the nesting depth of the current task on that semaphore,

We _really_ don't want to have function names like "cs_up()" and
"cs_down()".

Please either call them something half-way readable, like "cpuset_lock()"
and "cpuset_unlock()". Yes, it's a local static function, but still.. No
need to be cryptic about it.

Linus
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/