Re: p = kmalloc(sizeof(*p), )

From: Pekka Enberg
Date: Tue Sep 20 2005 - 06:22:57 EST


Hi,

On 9/18/05, Russell King <rmk+lkml@xxxxxxxxxxxxxxxx> wrote:
> 1. The above implies that the common case is that we are changing the
> names of structures more frequently than we change the contents of
> structures. Reality is that we change the contents of structures
> more often than the names of those structures.
>
> Why is this relevant? If you change the contents of structures,
> they need checking for initialisation. How do you find all the
> locations that need initialisation checked? Via grep. The problem
> is that:
>
> p = kmalloc(sizeof(*p), ...)
>
> is not grep-friendly, and can not be used to identify potential
> initialisation sites. However:
>
> p = kmalloc(sizeof(struct foo), ...)
>
> is grep-friendly, and will lead you to inspect each place where
> such a structure is allocated for correct initialisation.

I would disagree on this one. You can still grep all the places where
the local variable is declared in. Furthermore, structs are not always
initialized where they're kmalloc'd so you need to manually inspect
anyway.

On 9/18/05, Russell King <rmk+lkml@xxxxxxxxxxxxxxxx> wrote:
> 2. in the rare case that you're changing the name of a structure, you're
> grepping the source for all instances for struct old_name, or doing
> a search and replace for struct old_name. You will find all instances
> of struct old_name by this method and the bug alluded to will not
> happen.

Perhaps it has poor wording but I was more thinking about a case where
you shuffle code around and forget that you changed a struct to
something else (not necessarily removing the old one).

On 9/18/05, Russell King <rmk+lkml@xxxxxxxxxxxxxxxx> wrote:
> So the assertion above that kmalloc(sizeof(*p) is somehow superiour is
> rather flawed, and as such should not be in the Coding Style document.

I think it is better because:

- It is easier to get right.
- It is easier to audit with a script.
- It is shorter.

I am not saying you can use sizeof(*p) everywhere but it is the common
case and as such the preferred form.

Pekka
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/