Re: PS/2 Keyboard under 2.6.x

From: Michael Krufky
Date: Mon Oct 10 2005 - 23:16:19 EST

Mark Knecht wrote:

On 10/10/05, Robert Crocombe <rwcrocombe@xxxxxxxxxxxx> wrote:

I have a Microway system based around the Tyan Thunder K8QS Pro
motherboard (4x Opterons). Under recent versions of 2.6:


the PS/2-connected keyboard becomes unresponsive once the kernel has
booted (I can use it to select which kernel to boot in grub -- actually,
it must be present to keep the system from whining and asking me to
press F1). A USB keyboard works (I am composing this message from the
affected machine). I attempted using earlier versions of the kernel,
but they do not compile before 2.6.12, and if you go far enough back
'make menuconfig' doesn't work (I found and fixed the minor error that
was reported, but haven't attempted to build those kernels again).

I just reported this problem on the Gentoo bugzilla a couple of days
ago. Here I have a P4HT machine. I had never turned on SMP to use the
hyperthreading feature. When I turned it on I got exactly the problem
you talk about. When I went back to UMP it worked fine.

My keyboard is a wireless thing that had a little dongle to make it
into ps2. I took that off and used the keyboard as a USB keyboard and
it works fine under SMP.

This was on 2.6.13-gentoo-r3 for me.

Have either of you tried the kernel boot option usb=handoff ? I had similar problems, and this fixed it for me.

Michael Krufky

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at