RE: AIC79xx fails built into kernel, but works as a module

From: Roger Heflin
Date: Fri Oct 14 2005 - 14:35:20 EST

Apparently things where only less troublesome with it loaded as
a module, eventually things still fell over.

Apparently here is the base issue:

The device I am using does not work with the Linux driver, and an
Adaptec 320 controller running at 320, it works with the same
controller running at 160. It fails under vanilla kernel,
and all other recent ones that we tried.

It will work on the same machine with Windows and a Adaptec 320
controller, but only if the windows machine has a new driver. The
error it gives looks very similar to a cabling issue, and we had
ruled out cabling as we had replaced all combinations of cables,
and tried 2 separate Adaptec cards both of which failed, and tried
different devices.

I works fine with a LSILogic 320 and the associated mpt driver.

I believe the OEM is going to be either fixing their device (if
it is their fault) , or informing Adaptec about the issue if they
believe it is an Adaptec driver issue.


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at