Re: [PATCH 1/3] vm: kswapd incmin

From: Nick Piggin
Date: Mon Nov 07 2005 - 18:07:11 EST


Marcelo Tosatti wrote:
Hi Nick,

Looks nice, much easier to read than before.


Hi Marcelo,

Thanks! That was one of the main aims.

One comment: you change the pagecache/slab scanning ratio by moving
shrink_slab() outside of the zone loop.

This means that for each kswapd iteration will scan "lru_pages" SLAB entries, instead of "lru_pages*NR_ZONES" entries.

Can you comment on that?


I believe I have tried to get it right, let me explain. lru_pages
is just used as the divisor for the ratio between lru scanning
and slab scanning. So long as it is kept constant across calls to
shrink_slab, there should be no change in behaviour.

The the nr_scanned variable is the other half of the equation that
controls slab shrinking. I have changed from:

lru_pages = total_node_lru_pages;
for each zone in node {
shrink_zone();
shrink_slab(zone_scanned, lru_pages);
}

To:

lru_pages = 0;
for each zone in node {
shrink_zone();
lru_pages += zone_lru_pages;
}
shrink_slab(total_zone_scanned, lru_pages);

So the ratio remains basically the same
[eg. 10/100 + 20/100 + 30/100 = (10+20+30)/100]

2 reasons for doing this. The first is just efficiency and better
rounding of the divisions.

The second is that within the for_each_zone loop, we are able to
set all_unreclaimable without worrying about slab, because the
final shrink_slab at the end will clear all_unreclaimable if any
zones have had slab pages freed up.

I believe it generally should result in more consistent reclaim
across zones, and also matches direct reclaim better.

Hope this made sense,
Nick

--
SUSE Labs, Novell Inc.

Send instant messages to your online friends http://au.messenger.yahoo.com -
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/