Re: [PATCH 2/11] LED: Add LED Class

From: Greg KH
Date: Tue Jan 31 2006 - 20:45:32 EST


On Tue, Jan 31, 2006 at 09:41:37PM +0000, Richard Purdie wrote:
> On Tue, 2006-01-31 at 12:59 -0800, Greg KH wrote:
> > On Tue, Jan 31, 2006 at 01:41:28PM +0000, Richard Purdie wrote:
> > > +/**
> > > + * led_device_register - register a new object of led_device class.
> > > + * @dev: The device to register.
> > > + * @led_dev: the led_device structure for this device.
> > > + */
> > > +int led_device_register(struct device *dev, struct led_device *led_dev)
> >
> > Shouldn't struct led_device contain a struct device within it, like the
> > rest of the driver model?
>
> The code supports more than one led per struct device.
>
> Perhaps the name is misleading and should be led_class_register?

Yes, that would make more sense, and have the struct device * be called
"parent".

> The code has changed a lot through its various development stages (it
> did start out as a device IIRC).
>
> led_device should also probably be led_class by that argument...

Yes.

thanks,

greg k-h
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/