Re: [PATCH 02/17] mips: namespace pollution - mem_... -> __mem_... in io.h

From: Al Viro
Date: Wed Feb 08 2006 - 11:31:11 EST

On Wed, Feb 08, 2006 at 04:21:45PM +0000, Maciej W. Rozycki wrote:
> On Wed, 8 Feb 2006, Al Viro wrote:
> > > Then the corresponding ones with no "mem_" prefix (these for the PCI I/O
> > > port space) should be prefixed with "__" for consistency as well.
> >
> > Huh???
> >
> > Things like outb(), etc. *are* public; mem_... ones are not.
> I mean if we rename e.g. mem_ioswabb() to __mem_ioswabb(), then we should
> rename ioswabb() to __ioswabb() as well. Sorry for not having been clear
> enough, but I have assumed it is obvious.

In principle that would be nice, but... Take a look at those macros.
We can do that, but it would mean #define readb __readb, etc. Since
really nasty clashes are in mem_inb() (let's face it, coming up
with one of those is far more likely than using ioswabb() for driver-internal
purposes) I've stopped at that. Can do a followup switching to __ioswab...
and adding defines compensating for changes in visible symbols, but IMO
that's a separate patch...
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at