[PATCH] for_each_possible_cpu [1/19] defines for_each_possible_cpu

From: KAMEZAWA Hiroyuki
Date: Wed Mar 15 2006 - 22:20:01 EST


Now,
for_each_cpu() is for-loop cpu over cpu_possible_map.
for_each_online_cpu is for-loop cpu over cpu_online_map.
.....for_each_cpu() looks bad name.

This patch renames for_each_cpu() as for_each_possible_cpu().

I also wrote patches to replace all for_each_cpu with for_each_possible_cpu.
please confirm....

BTW, when HOTPLUC_CPU is not suppoted, using for_each_possible_cpu()
should be avoided, I think.

all patches are against 2.6.16-rc6-mm1.

Signed-Off-By: KAMEZAWA Hiroyuki <kamezawa.hiroyu@xxxxxxxxxxxxxx>

Index: linux-2.6.16-rc6-mm1/include/linux/cpumask.h
===================================================================
--- linux-2.6.16-rc6-mm1.orig/include/linux/cpumask.h
+++ linux-2.6.16-rc6-mm1/include/linux/cpumask.h
@@ -67,7 +67,7 @@
*
* int any_online_cpu(mask) First online cpu in mask
*
- * for_each_cpu(cpu) for-loop cpu over cpu_possible_map
+ * for_each_possible_cpu(cpu) for-loop cpu over cpu_possible_map
* for_each_online_cpu(cpu) for-loop cpu over cpu_online_map
* for_each_present_cpu(cpu) for-loop cpu over cpu_present_map
*
@@ -407,7 +407,7 @@ extern cpumask_t cpu_present_map;
cpu; \
})

-#define for_each_cpu(cpu) for_each_cpu_mask((cpu), cpu_possible_map)
+#define for_each_possible_cpu(cpu) for_each_cpu_mask((cpu), cpu_possible_map)
#define for_each_online_cpu(cpu) for_each_cpu_mask((cpu), cpu_online_map)
#define for_each_present_cpu(cpu) for_each_cpu_mask((cpu), cpu_present_map)

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/