RE: 2.6.16 hugetlbfs problem

From: Chen, Kenneth W
Date: Thu Mar 23 2006 - 00:41:10 EST

Mark Rustad wrote on Wednesday, March 22, 2006 3:33 PM
> >> I seem to be having trouble using hugetlbfs with kernel 2.6.16. I
> >> have a small test program that worked with 2.6.16-rc5, but fails with
> >> 2.6.16-rc6 or the release. The program is below. Given a path to a
> >> file on a hugetlbfs, it opens/creates the file, mmaps it and tries to
> >> access the first word. On 2.6.16-rc5, it works. On 2.6.16, it hangs
> >> page-faulting until it is killed.
> >
> > On what platform? Things like hugetlb and address space layout
> > (you're requesting a specific mmap() address I noticed) are very
> > platform specific.
> This is on a Xeon, without PAE with the 1GB no-highmem memory map, in
> all three cases. This is a 32-bit kernel running on a Nacona CPU. I
> also had an unmap call over the range to be mmap-ed, but the failure/
> success cases were the same, so I removed it to reduce the test
> program further.

It might be something else happening in your environment. I ran your test
code on a similar system. It ran just fine.

- Ken

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at