Re: [PATCH] pids: simplify do_each_task_pid/while_each_task_pid

From: Christoph Hellwig
Date: Thu Apr 13 2006 - 09:43:20 EST


On Thu, Apr 13, 2006 at 08:37:27PM +0400, Oleg Nesterov wrote:
> Simpllify do_each_task_pid/while_each_task_pid macros.
> This also makes the code a bit smaller.
>
> Signed-off-by: Oleg Nesterov <oleg@xxxxxxxxxx>
>
> --- MM/include/linux/pid.h~ 2006-03-23 22:48:10.000000000 +0300
> +++ MM/include/linux/pid.h 2006-04-13 20:28:53.000000000 +0400
> @@ -99,21 +99,16 @@ extern void FASTCALL(free_pid(struct pid
> pids[(type)].node)
>
>
> -/* We could use hlist_for_each_entry_rcu here but it takes more arguments
> - * than the do_each_task_pid/while_each_task_pid. So we roll our own
> - * to preserve the existing interface.
> - */
> -#define do_each_task_pid(who, type, task) \
> - if ((task = find_task_by_pid_type(type, who))) { \
> - prefetch(pid_next(task, type)); \
> - do {
> -
> -#define while_each_task_pid(who, type, task) \
> - } while (pid_next(task, type) && ({ \
> - task = pid_next_task(task, type); \
> - rcu_dereference(task); \
> - prefetch(pid_next(task, type)); \
> - 1; }) ); \
> - }
> +#define do_each_task_pid(who, type, task) \
> + do { \
> + struct hlist_node *pos___; \
> + struct pid *pid___ = find_pid(who); \
> + if (pid___ != NULL) \
> + hlist_for_each_entry_rcu((task), pos___, \
> + &pid___->tasks[type], pids[type].node) {
> +
> +#define while_each_task_pid(who, type, task) \
> + } \
> + } while (0)

This is prtty ugly. Can't we just have a

#define for_each_task_pid(task, pid, type, pos) \
hlist_for_each_entry_rcu((task), (pos), \
(&(pid))->tasks[type], pids[type].node) {

and move the find_pid to the caller? That would make the code a whole lot
more readable.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/