Re: 2.6.17-rc4-mm1 panic on boot

From: H. Peter Anvin
Date: Tue May 16 2006 - 04:45:54 EST

Followup to: <20060516001501.GA7528@localhost>
By author: lgouv@xxxxxxxx
In newsgroup:
> Just upgraded from rc3-mm4.
> Panic on boot with this message (copied by hand ):
> kinit:do_mount
> kinit: name_to_dev_t(/dev/hda8) = dev (0,0)
> kinit:rot_dev = dev (0,0)
> kinit root_dev = dev (0,0)
> kinit trying to mount /dev/root on /root
> ...........
> /dev/hda8 is my root partition but I suppose dev (0,0) is the first
> partition on hda which is FAT.
> I tried vanilla rc4 with the same result.

This means kinit couldn't find a name-to-number mapping for the string
/dev/hda8. However, you said you tried vanilla rc4 with the same
result, and vanilla rc4 doesn't use klibc.

This means hda8 simply isn't discovered on your system, which probably
means hda isn't discovered. This typically is an issue with your
kernel configuration, but it's not always.

There should be somewhere in your boot messages a message such as the

Probing IDE interface ide0...
hda: WDC WD2500JB-00EVA0, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hda: max request size: 1024KiB
hda: 488397168 sectors (250059 MB) w/8192KiB Cache, CHS=30401/255/63,
hda: cache flushes supported
hda: hda1 hda2 hda3 hda4

Does this show up in your successful boots? Failing boots?

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at