Re: [PATCH 4/4] Streamline generic_file_* interfaces and filemap cleanups
Date: Tue May 16 2006 - 06:51:13 EST
On Tue, May 16, 2006 at 08:28:04AM +1000, Nathan Scott wrote:
> I know its not something you're introducing here, but the naming
> convention do_sync_read/do_sync_write is pretty confused (with it
> not actually being a sync write and all, in the usual case).
> Any chance that could be renamed to something thats a bit clearer,
> maybe generic_file_non_aio_read and generic_file_non_aio_write?
> There don't seem to be many callsites (so not a huge change) and
> it'd seem a good time to do it, alongside these other changes.
I agree that the current naming is rather odd. generic_file_* on the
other hand would be completely wrong - generic_file_* are the generic
pagecache routines, these are wrappers to use ->aio_read/->aio_write.
Currently I can't imagine a better name, though.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/