Re: USB net driver hacker wanted (was Re: Bug related to bonding)

From: Willy Tarreau
Date: Wed May 17 2006 - 16:54:42 EST

On Wed, May 17, 2006 at 08:31:20PM +0200, Heiko Gerstung wrote:
> Hi List!
> I am still having problems with rtl8150.c on Linux 2.4.32 ...
> Willy Tarreau wrote:
> >> Please find below the complete async_get_registers function I set up, I
> >> hope it's OK to post it here. A kernel hacker will immediately spot the
> >> error, no? :-)
> >>
> > Just a guess : I suspect that dev->ctrl_urb is NULL. I don't know how you
> > are supposed to initialize it though.
> >
> You were right :-) It was a question of how things get initialized.
> My current state is that I am able to load the module but using my
> async_get_register function does not succeed due to timeouts. I am no
> kernel hacker and therefore it is like running through the darkest night
> with my sunglasses on :-) ... I sincerely hope, the maintainer of the
> driver helps me out...

I have no clue in this area either, unfortunately.

> It is interesting to see that with a 2.4.20 kernel I have no problems
> with loading the driver, it only crashes when I run net-snmp on it and
> then fire up an snmpwalk (which, I guess, queries the driver for some
> interface statistics or something like that).

You mean the bonding driver ? Older versions did not support ethtool ioctl(),
but only MII calls. I don't remember at what version it changed, but I suspect
from what you're saying that your driver might work if you disable ethtool.

Take a look at the bonding driver, there's a place where it first tries if
ethtool is supported on the driver, and if not it uses MII. I think that
commenting out one "if" statement would be close to enough.

> Deadline is coming and still no hope, yet. We'll see...

There's always hope, you have all the code :-)

> Kind regards,
> Heiko


To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at