Re: [PATCH 2/2] list.h doc: change "counter" to "control"

From: Andrew Morton
Date: Fri May 19 2006 - 12:04:39 EST

"Randy.Dunlap" <rdunlap@xxxxxxxxxxxx> wrote:
> On Fri, 19 May 2006 10:37:28 -0500 Scott Preece wrote:
> > I agree that "counter" is wrong, but "control" is still a little
> > vague. How about:
> > "the &struct list_head that tracks iteration over the list" or
> > "the &struct list_head that tracks current location in list."
> I considered "iterator" (but that's the macro itself I think),
> "control", "variable", "pointer", and "position".
> "current location" would be OK with me.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at