Re: 2.6.16-rt22/23 kernels hanging after registering IO schedulers

From: Steven Rostedt
Date: Mon May 22 2006 - 17:27:18 EST

On Sun, 2006-05-21 at 14:10 -0700, Mark Knecht wrote:

> Hi Steve,
> It's good to hear from you and great if you can take a look at
> this. I did some more ground work and now feel bad that I didn't
> report back much earlier. It appears that the problems have started
> with the very first revision of 2.6.16-rt support. I am currently
> writing you from 2.6.16 from which booted fine. However
> 2.6.16-rt1 fails the same way as all the later kernels that I tried
> with a hang right after registering the schedulers.

You're getting farther than I am. My system crashes in init_8259A right
in the unlocking of the i8259A_lock. It takes an exception in the
local_irq_restore of the raw_spin_unlock_irqrestore. I tried unlocking
the lock and locking it again at the beginning of the function, and that
seems to work fine. But this function didn't change between the
previous versions that do work. So I think something is very wacky
going on someplace else.

Unfortunately, I'm very behind in the work that I get paid for, so I
really don't have any more time to look into this. Especially since my
main developing machine happens to be my x86_64.

Hopefully, Ingo can find something, or I catch up and can work on this

-- Steve

Here's my dump:

IOAPIC[0]: apic_id 2, version 17, address 0xfec00000, GSI 0-23
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 high level)
ACPI: INT_SRC_OVR (bus 0 bus_irq 14 global_irq 14 high edge)
ACPI: INT_SRC_OVR (bus 0 bus_irq 15 global_irq 15 high edge)
Setting APIC routing to flat
Using ACPI (MADT) for SMP configuration information
Allocating PCI resources starting at 80000000 (gap: 7ff00000:60100000)
Real-Time Preemption Support (C) 2004-2006 Ingo Molnar
Built 1 zonelists
Kernel command line: root=/dev/md0 ro console=ttyS0,115200 console=tty0
Initializing CPU#0
WARNING: experimental RCU implementation.
PANIC: early exception rip 10 error ffffffff8034d270 cr2 f0aeaa

Call Trace:
RIP 0x10

> To try finding a place where the problem started I also tried
> 2.6.15-rt21 which was the last 2.6.15-rt kernel in the pro-audio
> overlay. That kernel works fine also so it seems to be something right
> at the beginning of the 2.6.16 series.
> If this could possibly be something in my .config files let me know
> and I'll try making changes directed by you or Ingo there.
> I hope this info might help you get to the problem a little more quickly.
> Cheers,
> Mark

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at