problem of module SX8

From: Александр Садков
Date: Tue May 23 2006 - 17:13:48 EST

I wish to inform on a problem of module SX8 in kernels 2.6.15SMP and 2.6.16SMP.

SuperMicro 370DLE, 2xIntel PIII800EB
Promise SATAII150 SX8 (latest firmware, Command Query – Disabled)
System HDD - Western Digital WD1500ADFD (SATA)
Data HDD – 4 x Seagate Barracuda 7200.9 ST3500641AS (SATA)

The equipment was tested under Windows XP in various modes.
All perfectly worked except that it Windows...

In Linux FC5 (all updates) kernel 2.6.15SMP or 2.6.16SMP the system behaved as follows:

If to connect only system HDD Western Digital that all works, but I periodically receive messages of type:
cell kernel: end_request: I/O error, dev sx8/0, sector 220064
cell kernel: Buffer I/O error on device sx8/0, logical block 27508

If to connect all HDD it quickly enough leads to lag of one, several or all HDD connected to SX8.
The system does not give out any mistakes, any command leads to freezing of the console, helps only reset.

Following recommendations, I have tried to transfer module SX8 parameter max_queue = 30.
During loading the system has destroyed root file system.

Having restored with Backup, I tried to establish max_queue = 2, that also have destroyed root file system.

I am sorry for bad English.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at