Re: [PATCH 2/2] iWARP Core Changes.

From: Stephen Hemminger
Date: Wed May 31 2006 - 14:35:29 EST


On Wed, 31 May 2006 13:26:55 -0500
Steve Wise <swise@xxxxxxxxxxxxxxxxxxxxx> wrote:

>
> This patch contains modifications to the existing rdma header files,
> core files, drivers, and ulp files to support iWARP.
> ---
>
> drivers/infiniband/core/Makefile | 4
> drivers/infiniband/core/addr.c | 8 -
> drivers/infiniband/core/cache.c | 8 -
> drivers/infiniband/core/cm.c | 3
> drivers/infiniband/core/cma.c | 349 +++++++++++++++++++++++---
> drivers/infiniband/core/device.c | 6
> drivers/infiniband/core/mad.c | 11 +
> drivers/infiniband/core/sa_query.c | 5
> drivers/infiniband/core/smi.c | 18 +
> drivers/infiniband/core/sysfs.c | 18 +
> drivers/infiniband/core/ucm.c | 5
> drivers/infiniband/core/user_mad.c | 9 -
> drivers/infiniband/hw/ipath/ipath_verbs.c | 2
> drivers/infiniband/hw/mthca/mthca_provider.c | 2
> drivers/infiniband/ulp/ipoib/ipoib_main.c | 8 +
> drivers/infiniband/ulp/srp/ib_srp.c | 2
> include/rdma/ib_addr.h | 15 +
> include/rdma/ib_verbs.h | 39 +++
> 18 files changed, 427 insertions(+), 85 deletions(-)
>
> diff --git a/drivers/infiniband/core/Makefile b/drivers/infiniband/core/Makefile
> index 68e73ec..163d991 100644
> --- a/drivers/infiniband/core/Makefile
> +++ b/drivers/infiniband/core/Makefile
> @@ -1,7 +1,7 @@
> infiniband-$(CONFIG_INFINIBAND_ADDR_TRANS) := ib_addr.o rdma_cm.o
>
> obj-$(CONFIG_INFINIBAND) += ib_core.o ib_mad.o ib_sa.o \
> - ib_cm.o $(infiniband-y)
> + ib_cm.o iw_cm.o $(infiniband-y)
> obj-$(CONFIG_INFINIBAND_USER_MAD) += ib_umad.o
> obj-$(CONFIG_INFINIBAND_USER_ACCESS) += ib_uverbs.o ib_ucm.o
>
> @@ -14,6 +14,8 @@ ib_sa-y := sa_query.o
>
> ib_cm-y := cm.o
>
> +iw_cm-y := iwcm.o
> +
> rdma_cm-y := cma.o
>
> ib_addr-y := addr.o
> diff --git a/drivers/infiniband/core/addr.c b/drivers/infiniband/core/addr.c
> index d294bbc..5a9be54 100644
> --- a/drivers/infiniband/core/addr.c
> +++ b/drivers/infiniband/core/addr.c
> @@ -60,12 +60,15 @@ static LIST_HEAD(req_list);
> static DECLARE_WORK(work, process_req, NULL);
> static struct workqueue_struct *addr_wq;
>
> -static int copy_addr(struct rdma_dev_addr *dev_addr, struct net_device *dev,
> +int copy_addr(struct rdma_dev_addr *dev_addr, struct net_device *dev,
> unsigned char *dst_dev_addr)

If you have to make this global choose a better name than 'copy_addr'
and change dst_dev_addr to be const.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/