Re: [patch 07/61] lock validator: better lock debugging

From: Andrew Morton
Date: Fri Jun 23 2006 - 07:05:40 EST


On Fri, 23 Jun 2006 12:25:23 +0200
Ingo Molnar <mingo@xxxxxxx> wrote:

>
> * Andrew Morton <akpm@xxxxxxxx> wrote:
>
> > > +#define DEBUG_WARN_ON(c) \
> > > +({ \
> > > + int __ret = 0; \
> > > + \
> > > + if (unlikely(c)) { \
> > > + if (debug_locks_off()) \
> > > + WARN_ON(1); \
> > > + __ret = 1; \
> > > + } \
> > > + __ret; \
> > > +})
> >
> > Either the name of this thing is too generic, or we _make_ it generic,
> > in which case it's in the wrong header file.
>
> this op is only intended to be used only by the lock debugging
> infrastructure. So it should be renamed - but i fail to find a good name
> for it. (it's used quite frequently within the lock debugging code, at
> 60+ places) Maybe INTERNAL_WARN_ON()? [that makes it sound special
> enough.] DEBUG_LOCKS_WARN_ON() might work too.

Well it has a debug_locks_off() in there, so DEBUG_LOCKS_WARN_ON() seems right.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/