Re: [PATCH] genirq: ARM dyntick cleanup

From: Ingo Molnar
Date: Mon Jul 03 2006 - 03:00:38 EST



* Thomas Gleixner <tglx@xxxxxxxxxxxxx> wrote:

> > btw, is this, from include/linux/irq.h:
> >
> > /*
> > * Please do not include this file in generic code. There is currently
> > * no requirement for any architecture to implement anything held
> > * within this file.
> > *
> > * Thanks. --rmk
> > */
> >
> > still true?
>
> I think what it means is that linux/irq.h must not be included in
> drivers. drivers should include linux/interrupt.h instead.

Christoph has had ideas for cleanups in the irq-header-files area for a
long time. My rough battleplan would be this:

- linux/interrupt.h should remain the highlevel driver API [which can be
used by both physical (genirq or non-genirq) or virtual platforms].
Only this file should be included by drivers.

- rename linux/irq.h to linux/irqchips.h, to make it less likely for
drivers to include it accidentally.

- rename asm/irq.h to asm/irqchips.h

- most of linux/hardirq.h should merge into interrupt.h [the rest into
linux/irqchips.h] and hardirq.h should be eliminated.

- merge asm/hardirq.h and asm/hw_irq.h into asm/irqchips.h.

Christoph, agreed?

Ingo
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/