Re: [PATCH 00/12] making the kernel -Wshadow clean - The initialstep

From: Jan Engelhardt
Date: Tue Aug 01 2006 - 02:49:53 EST

>> I think it's a good thing that we have to take a little more care when
>> choosing global function and variable names... Take up() for example -
>> in my (very humble) oppinion that is a very bad name for a global
>> function - it clashes too easily with local function and variable
>> names, and a programmer who's not careful may end up calling the
>> global up() when he wants the local and vice versa (a much better name
>> would have been sem_up() - should we change that???).
>(authors of (yet) off-tree things would hate us)

Mark up() as deprecated while sem_up() emerges - hey, we even have an
__attribute__(()) for that..

Jan Engelhardt
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at