Re: [PATCH 004 of 9] md: Factor out part of raid10d into a separatefunction.

From: Neil Brown
Date: Tue Aug 01 2006 - 16:25:34 EST

On Tuesday August 1, davidsen@xxxxxxx wrote:
> don't think this is better, NeilBrown wrote:
> >raid10d has toooo many nested block, so take the fix_read_error
> >functionality out into a separate function.
> >
> >
> Definite improvement in readability. Will all versions of the compiler
> do something appropriate WRT inlining or not?

As the separated function is called about once in a blue moon, it
hardly matters. I'd probably rather it wasn't inlined so as to be
sure it doesn't clutter the L-1 cache when it isn't needed, but that's
the sort of thing I really want to leave to the compiler.

Maybe it would be good to stick an 'unlikely' or 'likely' in raid10d
to tell the compiler how likely a read error is...

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at