Re: [PATCH 1/2] include/linux: Defining bool, false and true

From: ricknu-0
Date: Tue Aug 01 2006 - 17:11:16 EST

Citerar "H. Peter Anvin" <hpa@xxxxxxxxx>:

> ricknu-0@xxxxxxxxxxxxxx wrote:
> > This patch defines:
> > * a generic boolean-type, named "bool"
> > * aliases to 0 and 1, named "false" and "true"
> >
> > Signed-off-by: Richard Knutsson <ricknu-0@xxxxxxxxxxxxxx>
> Shouldn't this simply use _Bool?

Well, it is (now) just a typedef of it. :)

But I find it better, both because it is more similar to the common types:
short, lowlettered words. But also because most editors with highlightning
recognize "bool", but not "_Bool", as a type (as I found it).

> -hpa

/Richard Knutsson

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at