Re: [PATCH 1/2] include/linux: Defining bool, false and true

From: H. Peter Anvin
Date: Tue Aug 01 2006 - 17:40:21 EST

Jeff Garzik wrote:
H. Peter Anvin wrote:
ricknu-0@xxxxxxxxxxxxxx wrote:
This patch defines:
* a generic boolean-type, named "bool"
* aliases to 0 and 1, named "false" and "true"

Signed-off-by: Richard Knutsson <ricknu-0@xxxxxxxxxxxxxx>

Shouldn't this simply use _Bool?

No sane person should use "_Bool" in real code. Unnecessary StudlyCaps and unnecessary underscore.

"bool" is far easier to type, and looks less weird.

That wasn't the point. The point was that bool should be a typedef to _Bool instead of an enum.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at