Re: [patch] x86: rename is_at_popf(), add iret to tests and fix insn length

From: Andi Kleen
Date: Wed Aug 02 2006 - 18:11:07 EST

On Wednesday 02 August 2006 15:35, Chuck Ebbert wrote:
> In-Reply-To: <200608021454.33685.ak@xxxxxxx>
> On Wed, 2 Aug 2006 14:54:33 +0200. Andi Kleen wrote:
> > > is_at_popf() needs to test for the iret instruction as well as
> > > popf. So add that test and rename it to is_setting_trap_flag().
> >
> > Do you have a single real example where anybody is actually using IRET
> > in user space?
> No, but Albert Cahalan complained so I figured it should be fixed.

I suppose he just collected all the obscure FIXMEs in the code he could find.
Ok I merged it, but only because it is so little code.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at