Re: Completely dead on resume (no caps lock, nada)

From: Joseph Fannin
Date: Fri Aug 04 2006 - 17:57:26 EST

On Fri, Aug 04, 2006 at 12:56:18PM -0700, Brannon Barrett Klopfer wrote:
> Hello,
> Sorry to bug the entire list with such a vaugue post, but I'm not sure what
> driver/subsystem is causing this problem. I'm sure you all are sick of "My
> computer won't suspend, what do I do?" posts, but...well, my computer won't
> suspend...

If no one reports bugs, they don't get fixed.

Pavel Machek <pavel@xxxxxxx> is the swsusp maintainer, and should
have been CC'd on this, otherwise he'll probably never see it.
Linux-kernel is a busy place. :-)

I know Mr. Machek wants swsusp bug reports filed in Bugzilla at , so you should do that, and then send a
follow up to this, CC'd to Pavel, with a bugzilla bug number.

CC'ing Rafael J. Wysocki <rjw@xxxxxxx> as well probably wouldn't hurt.

> It's a brand-new HP dv8000t laptop (Phoenix BIOS, latest version, core duo,
> ahci/ata_piix [native/legacy]). Suspending (echo mem > /sys/power/state)
> works fine, but upon resuming, absolutly nothing works -- backlight stays
> off, caps/numlock, network, etc. all dead. I've also tried
> # cat `which poweroff` > /dev/null # cache it, in case disk dies upon resume
> # echo mem > /sys/power/state ; poweroff -f
> but it still just hangs (i.e., seems the entire system is just...dead). I've
> tried numerous patches from here and there, and tried both native (ahci) and
> legacy (ata_piix) sata, and a kernel with as little support as possible --
> no usb, ide, smp, module, preempt, etc. I won't flood the lists with other
> info, but it's all at
> I'd be more than happy to try patches/let someone ssh into my box if it'd
> help (new, so nothing sensitive on it yet).
> Thanks,
> Brannon Klopfer

Thank you.

Joseph Fannin

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at