Re: [PATCH] Turn rdmsr, rdtsc into inline functions, clarify names

From: Rusty Russell
Date: Sat Aug 05 2006 - 23:50:39 EST

On Sat, 2006-08-05 at 20:11 -0700, H. Peter Anvin wrote:
> Rusty Russell wrote:
> >>>
> >>> So if you would prefer u64 rdtsc64(), u32 rdtsc_low(), u64 rdmsr64(int
> >>> msr), u32 rdmsr_low(int msr), I can convert everyone to that, although
> >>> it's a more invasive change...
> >> rdmsrl is really misnamed. It should have been rdmsrq to be consistent,
> >> and have rdmsrl return the low 32 bits.
> >
> > I prefer the more explicit linux-style naming of rdmsr_low32/rdmsr64,
> > myself, even though this is x86-specific code. Noone has an excuse for
> > misunderstanding then...
> Well, we *do* have readb/readw/readl/readq etc.

Exactly. And I modelled the name rdtsc64 on the "new-style" ioread8,
ioread16 and ioread32 from asm-generic/iomap.h 8)

Help! Save Australia from the worst of the DMCA:

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at