Re: [PATCH 02/12] hdaps: Use thinkpad_ec instead of direct port access

From: Shem Multinymous
Date: Mon Aug 07 2006 - 11:38:08 EST


On 8/7/06, Pavel Machek <pavel@xxxxxxx> wrote:
> +#define ABORT_INIT(msg) { printk(KERN_ERR "hdaps init: %s\n", msg); goto bad; }

No.. macro with embedded goto is *evil*.

OK. But it does makes the init function much longer and harder to read.


> + if (data.val[0xF]!=0x00)
> + ABORT_INIT("check1");

!=0 in if is evil...

Sure, when zero is special, like for booleans or integer or pointers.
But this is a status byte value, I don't want to mistreat it just
because all its bits are unset. Otherwise, imagine the non-systematic
mess this will become:

if (data.val[0x1]!=0x00 ||
data.val[0x2]!=0x60 ||
data.val[0x3]!=0x00 ||
data.val[0xF]!=0x00)
ABORT_INIT("check2");

> + if (mode==0x00)

if !mode ?

Likewise.

Shem
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/