[PATCH 2/2] UML - use ptrace-abi.h instead of ptrace.h

From: Jeff Dike
Date: Tue Aug 08 2006 - 16:56:29 EST


Include the host architecture's ptrace-abi.h instead of ptrace.h.

There was some cpp mangling of names around the ptrace.h include to
avoid symbol clashes between UML and the host architecture. Most of
these can go away. The exception is struct pt_regs, which is
convenient to have in userspace, but must be renamed in order that UML
can define its own.

Signed-off-by: Jeff Dike <jdike@xxxxxxxxxxx>

Index: linux-2.6.18-mm/include/asm-um/ptrace-generic.h
===================================================================
--- linux-2.6.18-mm.orig/include/asm-um/ptrace-generic.h 2006-08-06 14:51:28.000000000 -0400
+++ linux-2.6.18-mm/include/asm-um/ptrace-generic.h 2006-08-06 20:35:20.000000000 -0400
@@ -8,18 +8,9 @@

#ifndef __ASSEMBLY__

-
#define pt_regs pt_regs_subarch
-#define show_regs show_regs_subarch
-#define send_sigtrap send_sigtrap_subarch
-
-#include "asm/arch/ptrace.h"
-
+#include "asm/arch/ptrace-abi.h"
#undef pt_regs
-#undef show_regs
-#undef send_sigtrap
-#undef user_mode
-#undef instruction_pointer

#include "sysdep/ptrace.h"


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/