Re: cpufreq stops working after a while

From: Mark Lord
Date: Fri Aug 11 2006 - 15:59:05 EST

Mark Lord wrote:
Dave Jones wrote:

boot with cpufreq.debug=7, and capture dmesg output after it fails
to transition. This might be another manifestation of the mysterious
"highest frequency isnt accessable" bug, that seems to come from
some recent change in acpi.

booting with that option doesn't seem to give me any new messages
in dmesg (or /var/log/messages). I also tried editing cpufreq.c
and hardcoding debug = 7 on the variable declaration.
Still no new messages.

Mmm.. that's interesting.. this time, the scaling_max_freq went back up
to 1100000 all by itself after a longish idle period, before which it had
dropped to 800000 and got "stuck" there.

Currently using the "ondemand" governor -- it doesn't seem to call the
central cpufreq_debug_printk() thingie from cpufreq.c.

I did hack cpufreq_debug_printk() to force output anytime it gets called,
but still no new output in the logs.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at