Re: powerpc: "make install" broken

From: Alex Riesen
Date: Sat Aug 12 2006 - 10:56:56 EST

On 8/12/06, Sam Ravnborg <sam@xxxxxxxxxxxx> wrote:
> I don't know if ever worked before, just tried today on v2.6.17.
> Maybe it works, but then it is very different to i386
> where it is plain "make install".
> I copied the implementation attached from i386 (modified a bit), which
> fixed it for me. Maybe the patch will motivate someone to fix it properly...
NACK - the install target shall not try to build the kernel - the
vmlinux dependency is long gone from i386.

Agreed, updated, rediffed, attached
(sorry for attach, that's gmail).
diff --git a/arch/powerpc/Makefile b/arch/powerpc/Makefile
index ed5b26a..85b0c4b 100644
--- a/arch/powerpc/Makefile
+++ b/arch/powerpc/Makefile
@@ -156,6 +156,9 @@ boot := arch/$(ARCH)/boot
$(BOOT_TARGETS): vmlinux
$(Q)$(MAKE) ARCH=ppc64 $(build)=$(boot) $(patsubst %,$(boot)/%,$@)

+ $(Q)$(MAKE) ARCH=ppc64 $(build)=$(boot) BOOTIMAGE=$(KBUILD_IMAGE) install
define archhelp
@echo '* zImage - Compressed kernel image (arch/$(ARCH)/boot/zImage.*)'
@echo ' install - Install kernel using'
diff --git a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile
index 840ae59..6bfc3ec 100644
--- a/arch/powerpc/boot/Makefile
+++ b/arch/powerpc/boot/Makefile
@@ -209,7 +209,7 @@ extra-y += vmlinux.bin vmlinux.gz
@echo -n ' Image: $@ '
@if [ -f $@ ]; then echo 'is ready' ; else echo 'not made'; fi

- sh -x $(srctree)/$(src)/ "$(KERNELRELEASE)" vmlinux "$(INSTALL_PATH)" "$(BOOTIMAGE)"
+ sh $(srctree)/$(src)/ "$(KERNELRELEASE)" vmlinux "$(INSTALL_PATH)"

clean-files += $(addprefix $(objtree)/, $(obj-boot) vmlinux.strip)