Re: [PATCH] bitmap: bitmap_parse takes a kernel buffer instead of a user buffer

From: Joe Korty
Date: Wed Oct 04 2006 - 13:15:14 EST


On Wed, Oct 04, 2006 at 09:40:29AM -0700, Andrew Morton wrote:
> I think we can do a version which omits the kmalloc altogether:

> if (__get_user(c, ubuf++))
> return -EFAULT;
>
> (Note the s/get_user/__get_user/)

Nice. This eliminates the bulk of the get_user() overhead. And
it can be merged into Inaky's enum solution too, for something
that is both simple and efficient.

Joe
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/