cypress_m8 spews garbage on ppc64 but is ok on x86

From: Mike Frysinger
Date: Sun Dec 24 2006 - 02:01:28 EST

anyone tried using the cypress_m8 usb serial cable on a G5 ? just
tried it on a ppc64/ kernel and all i get back is garbage when
hooked up to serial console of a board running at 57600 baud

plugged the same cable into my x86 machine and it works OK there
Bus 001 Device 010: ID 04b4:5500 Cypress Semiconductor Corp. HID->COM
RS232 Adapter

plugged a pl2303 into the ppc64 and that worked fine too
Bus 001 Device 011: ID 067b:2303 Prolific Technology, Inc. PL2303 Serial Port

$ uname -a
Linux G5 #2 SMP Sun Dec 24 00:53:03 EST 2006 ppc PPC970MP,
altivec supported PowerMac11,2 GNU/Linux

$ stty -F /dev/ttyUSB0
speed 57600 baud; line = 0;
flush = ^U; min = 1; time = 5;
ignbrk -brkint -icrnl ixoff -imaxbel
-opost -onlcr
-isig -icanon -iexten -echo -echoe -echok -echoctl -echoke

find attached logs after doing `modprobe cypress_m8 debug=1`
* setup of /dev/ttyUSB0 to proper serial settings
* the board running `yes` and spewing "y" over the serial console to my machine

Attachment: cypress-yes.log.bz2
Description: BZip2 compressed data

Attachment: cypress-setup.log.bz2
Description: BZip2 compressed data