Re: Want comments regarding patch

From: Jan Engelhardt
Date: Fri Dec 29 2006 - 05:14:25 EST

On Dec 29 2006 07:57, Daniel MarjamÃki wrote:
> It was my goal to improve the readability. I failed.
> I personally prefer to use standard functions instead of writing code.
> In my opinion using standard functions means less code that is easier to read.

Hm in that case, what about having something like

void *memset_int(void *a, int x, int n) {
asm("mov %0, %%esi;
mov %1, %%eax;
mov %2, %%ecx;
repz movsd;",

in include/asm-i386/ and asm-x86_64/? (For x86_64, also a memset_long
that uses rsi/rax/rcx/movsq)