Re: irq 4: nobody cared and I/O errors on serial ports.

From: Jan Engelhardt
Date: Fri Dec 29 2006 - 12:14:26 EST

On Dec 29 2006 12:41, Sergei Organov wrote:
>It seems that the kernel has some problems/races in opening/closing of
>serial ports. Simple C program below just opens/closes a port in a loop:
>I've noticed 2 problems running this program. I run smp kernel
>(I've also tested Debian kernel, and it has the same issues) on
>hyper-threaded Pentium 4 CPU.

Also happens on on AMD AXP2000 (UP, CONFIG_SMP=y), standard
x86 pc serial port
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
00:09: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A

>1. When I run the program, I begin to get "irq 4: nobody cared" in dmesg even
> though the port is not connected (idle). Please find relevant part of dmesg
> below.

Running said program repeatedly produces one stack trace every 4
seconds (CONFIG_HZ=100). Maybe knowing this interval helps finding the
[ 9545.167750] Disabling IRQ #4
[ 9549.599704] Disabling IRQ #4
[ 9554.034803] Disabling IRQ #4
[ 9558.455093] Disabling IRQ #4
[ 9562.876508] Disabling IRQ #4

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at
Please read the FAQ at