Re: A CodingStyle suggestion

From: Randy Dunlap
Date: Sat Feb 03 2007 - 17:04:30 EST


On Sat, 3 Feb 2007 23:58:48 +0200 Ahmed S. Darwish wrote:

> Hi all,
>
> In CodingStyle Chapter 16 "Function return value and names", why not
> adding a comment about the favorable community way of checking the return
> value. ie:
>
> ret = do_method();
> if (ret) {
> /* deal with error */
> }
>
> and not other ways like:
>
> if (do_method()) or if ((ret = do_method()) > value) ...
>
> A patch is ready if the replies are positive.

I like it. Please cc: Andrew Morton <akpm@xxxxxxxx> on it.
Hopefully he will merge it.

---
~Randy
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/