Re: [patch] timer/hrtimer: take per cpu locks in sane order

From: Ingo Molnar
Date: Fri Mar 02 2007 - 08:12:49 EST



* Heiko Carstens <heiko.carstens@xxxxxxxxxx> wrote:

> - spin_lock(&new_base->lock);
> - spin_lock(&old_base->lock);
> + /*
> + * If we take a lock from a different cpu, make sure we have always
> + * the same locking order. That is the lock that belongs to the cpu
> + * with the lowest number is taken first.
> + */
> + lock1 = smp_processor_id() < cpu ? &new_base->lock : &old_base->lock;
> + lock2 = smp_processor_id() < cpu ? &old_base->lock : &new_base->lock;
> + spin_lock(lock1);
> + spin_lock(lock2);

looks good to me. Wouldnt this be cleaner via double_lock_timer() -
similar to how double_rq_lock() works in kernel/sched.c - instead of
open-coding it?

Ingo
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/