Re: [patch 1/7] libata: check for AN support

From: Kristen Carlson Accardi
Date: Wed Apr 25 2007 - 16:37:40 EST


On Wed, 25 Apr 2007 20:16:51 +0100
Matt Sealey <matt@xxxxxxxxxxxxxx> wrote:

> > +#define ata_id_has_AN(id) \
> > + ( (((id)[76] != 0x0000) && ((id)[76] != 0xffff)) && \
> > + ((id)[78] & (1 << 5)) )
>
> ??
>
> > --- 2.6-git.orig/include/linux/libata.h
> > +++ 2.6-git/include/linux/libata.h
> > @@ -136,6 +136,7 @@ enum {
> > ATA_DFLAG_CDB_INTR = (1 << 2), /* device asserts INTRQ when ready for CDB */
> > ATA_DFLAG_NCQ = (1 << 3), /* device supports NCQ */
> > ATA_DFLAG_FLUSH_EXT = (1 << 4), /* do FLUSH_EXT instead of FLUSH */
> > + ATA_DFLAG_AN = (1 << 5), /* device supports Async notification */
> > ATA_DFLAG_CFG_MASK = (1 << 8) - 1,
>
> Why don't the macros use the enums? It makes the code hard to read without
> painful cross-reference doesn't it? Surely (id)[76] & (ATA_DFLAG_AN) is a
> lot more readable than 1 << 5 - even if the flag is obviously that, a lot
> of values and registers can have 1 << 5 as a flag and mean a lot of different
> things.

It's really just a coincidence that the ATA_DFLAG_AN bit is the same as the bit
in the identify device word, so this would not be appropriate.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/