[PATCH -mm 0/4] swsusp: Fix hibernation/restore code ordering

From: Rafael J. Wysocki
Date: Fri May 25 2007 - 08:15:39 EST


Hi,

In the face of the recent change of suspend code ordering
(cf. http://marc.info/?l=linux-acpi&m=117938245931603&w=2) we should also
modify the code ordering in swsusp so that hibernation_ops->prepare() is
executed after device_suspend().

However, for this purpose it seems reasonable to eliminate the code duplication
between kernel/power/disk.c and kernel/power/user.c first.  By eliminating it
we can reduce the size of user.c quite substantially and remove the
maintenance difficulty with making essentially the same changes in two
different places.

Moreover, we should also remove the calls to "platform" functions from the
restore code path, since it doesn't carry out any power transition of the
system, but we generally need to disable the GPEs before the restore if the
'platform' hibernation mode has been used.  To do this, we can introduce
two new hibernation_ops to be used in the restore code.

Greetings,
Rafael

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/