Re: [PATCH] lib: Replace calls to __get_free_pages() with __get_dma_pages().

From: rae l
Date: Wed Jun 06 2007 - 03:34:43 EST


On 6/6/07, Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> wrote:
On Tue, 5 Jun 2007 16:58:57 -0400 (EDT)
"Robert P. J. Day" <rpjday@xxxxxxxxxxxxxx> wrote:

> Replace a couple calls to __get_free_pages() with the corresponding
> calls to __get_dma_pages().
>
> Signed-off-by: Robert P. J. Day <rpjday@xxxxxxxxxxxxxx>
>
> ---
>
> that's the lot of them.
>
> diff --git a/lib/swiotlb.c b/lib/swiotlb.c
> index 10c13ad..8fc38dc 100644
> --- a/lib/swiotlb.c
> +++ b/lib/swiotlb.c
> @@ -201,8 +201,7 @@ swiotlb_late_init_with_default_size(size_t default_size)
> bytes = io_tlb_nslabs << IO_TLB_SHIFT;
>
> while ((SLABS_PER_PAGE << order) > IO_TLB_MIN_SLABS) {
> - io_tlb_start = (char *)__get_free_pages(GFP_DMA | __GFP_NOWARN,
> - order);
> + io_tlb_start = (char *)__get_dma_pages(__GFP_NOWARN, order);

__get_dma_pages() is just pointless obfuscation. I think it'd be better to
go the other way: open-code the GFP_DMA at all callsites then send
__get_dma_pages() bitbucketwards.
thus __get_free_pages(GFP_DMA ...) can do better, I don't think
__get_dma_pages is needed.

--
Denis Cheng
Linux Application Developer
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/