Re: [PATCH -rt 1/5] workqueue: queue_work_cpu

From: Peter Zijlstra
Date: Sat Jul 14 2007 - 14:01:32 EST


On Sat, 2007-07-14 at 21:14 +0400, Oleg Nesterov wrote:
> On 07/14, Peter Zijlstra wrote:
> >
> > +int fastcall queue_work_cpu(struct workqueue_struct *wq, struct work_struct *work, int cpu)
> > +{
> > + int ret = 0;
> > +
> > + if (!test_and_set_bit(WORK_STRUCT_PENDING, work_data_bits(work))) {
> > + BUG_ON(!list_empty(&work->entry));
> > + __queue_work(wq_per_cpu(wq, cpu), work);
> > + ret = 1;
> > + }
> > + return ret;
> > +}
>
> Minor nit, we already have queue_delayed_work_on(), perhaps it should be named
> queue_work_on().

Yes, that makes sense. Shall do.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/