Re: Sparse fix for scsi_request_fn

From: Matthew Wilcox
Date: Tue Oct 23 2007 - 17:14:20 EST


On Mon, Oct 22, 2007 at 07:09:56PM -0700, Linus Torvalds wrote:
> Umm. This is why we write things like
>
> static void double_lock_balance(struct rq *this_rq, struct rq *busiest)
> __releases(this_rq->lock)
> __acquires(busiest->lock)
> __acquires(this_rq->lock)
> {
> ...
>
> ie your "__holds()" is nothing new, and should be written as
> a pair of __releases(x) and __acquires(x), which is more readable anyway
> (since it actually says what the function does!)

Thanks, I hadn't realised that sparse would unify the two declarations.

--
Intel are signing my paycheques ... these opinions are still mine
"Bill, look, we understand that you're interested in selling us this
operating system, but compare it to ours. We can't possibly take such
a retrograde step."
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/