Re: [PATCH] sysfs: add filter function to groups

From: Cornelia Huck
Date: Mon Oct 29 2007 - 13:18:44 EST


On Mon, 29 Oct 2007 11:57:51 -0500,
James Bottomley <James.Bottomley@xxxxxxxxxxxx> wrote:

> On Mon, 2007-10-29 at 17:54 +0100, Kay Sievers wrote:
> > On Mon, 2007-10-29 at 10:16 -0500, James Bottomley wrote:
> > > This patch is a first pass at adding a filter function to the group
> > > attributes, just to see how the idea flies. If everyone's OK with this,
> > > I think the next thing that we might do is add bitmap functions (so
> > > every bit in the bitmap has a name, but also might not appear) to
> > > groups.
> >
> > Bitmaps in the attribute groups?
>
> Actually, no ... that would spoil our one group for all devices rule.
> So they would be a set of helper functions for manipulating bitmaps, but
> the bitmap would have to be in separate storage elsewhere.

Can you determine which subset of the attributes you want just before
actually creating the group? Then you could do something like:

create_group(grp, kobj)
{
grp->update_creation_mask(kobj);
actually_create_attrs();
}

>
> > > struct attribute_group {
> > > const char *name;
> > > + int (*filter_show)(struct kobject *, int);
> >
> > Are you sure that you want to return an array index here, instead of the
> > actual attribute? Like:
>
> Actually, it returns a true/false value indicating whether the given
> attribute should be displayed.
>
> > int (*filter_show)(struct kobject *kobj, struct attribute *attr);

I'd agree that using the attribute is better in this function.

> >
> > The names "show" and "store" are the ususal file-operation names, and we
> > are not filtering a "show" here, right? Maybe "create", or "export", or
> > something else might be a better name?
>
> how about (*attribute_is_visible)?

Well, you don't only stop the visibility, but the creation of the
attribute, so perhaps (*creation_filter)?
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/