Re: Linux 2.6.24-rc5 x86 architecture no longer Oopses...

From: Andrew Morton
Date: Thu Dec 20 2007 - 19:42:53 EST


On Fri, 21 Dec 2007 01:30:35 +0100
Ingo Molnar <mingo@xxxxxxx> wrote:

>
> * Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> wrote:
>
> > On Fri, 21 Dec 2007 00:47:59 +0100
> > Ingo Molnar <mingo@xxxxxxx> wrote:
> >
> > > > __raw_spin_lock(&die.lock);
> > > > raw_local_save_flags(flags);
> > > > - die.lock_owner = smp_processor_id();
> > > > + die.lock_owner = raw_smp_processor_id();
> > >
> > > we just disabled irqs with raw_local_save_flags().
> >
> > <chases x86 spaghetti for a while>
> >
> > raw_local_save_flags() doesn't disable interrupts?
>
> argh. Indeed! (I wanted us to fix that misleading name eons ago, to

The naming of those functions is truly awful and it goes back to year 0.

> *_save_flags_only(), but some stupid bikeshed painting discussion
> prevented it from ever happening.)

local_read_flags().

> that should have been raw_local_irq_save(flags)!

So raw_local_save_flags() and raw_local_irq_save() have different semantics.

omigawd, what have we done?

> but ... why is it done like that? Why do we first take the die.lock and
> disable interrupts afterwards? It's highly weird. 64-bit does it all
> correctly in traps_64.c, so unification will help us out - but so far
> perhaps the patch below we should do in 2.6.24?
>
> Ingo
>
> ------------>
> Subject: x86: fix die() to not be preemptible
> From: Ingo Molnar <mingo@xxxxxxx>
>
> Andrew "Eagle Eye" Morton noticed that we use raw_local_save_flags()
> instead of raw_local_irq_save(flags) in die().
>
> do it correctly - and first disable interrupts, then take the spinlock.
>
> Signed-off-by: Ingo Molnar <mingo@xxxxxxx>
> ---
> arch/x86/kernel/traps_32.c | 7 +++----
> 1 file changed, 3 insertions(+), 4 deletions(-)
>
> Index: linux-x86.q/arch/x86/kernel/traps_32.c
> ===================================================================
> --- linux-x86.q.orig/arch/x86/kernel/traps_32.c
> +++ linux-x86.q/arch/x86/kernel/traps_32.c
> @@ -373,14 +373,13 @@ void die(const char * str, struct pt_reg
>
> if (die.lock_owner != raw_smp_processor_id()) {
> console_verbose();
> + raw_local_irq_save(flags);
> __raw_spin_lock(&die.lock);
> - raw_local_save_flags(flags);
> die.lock_owner = smp_processor_id();
> die.lock_owner_depth = 0;
> bust_spinlocks(1);
> - }
> - else
> - raw_local_save_flags(flags);
> + } else
> + raw_local_irq_save(flags);
>
> if (++die.lock_owner_depth < 3) {
> unsigned long esp;

Looks sane.

I suppose there's some reason why we can't just use spin_lock_irqsave().
But that reason was either so obvious or so unimportant that a comment was
not needed. Sigh.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/