Re: [PATCH 3/7] X86: Fix trailing statements should be on next line

From: Willy Tarreau
Date: Mon Jan 28 2008 - 18:45:15 EST


Hi Paolo,

On Tue, Jan 29, 2008 at 12:07:44AM +0100, Paolo Ciarrocchi wrote:
> Fix trailing statements should be on next line

> -if ( partial_status & SW_C3 ) printk("SW: condition bit 3\n");
> -if ( partial_status & SW_C2 ) printk("SW: condition bit 2\n");
> -if ( partial_status & SW_C1 ) printk("SW: condition bit 1\n");
> -if ( partial_status & SW_C0 ) printk("SW: condition bit 0\n");
> -if ( partial_status & SW_Summary ) printk("SW: exception summary\n");
> -if ( partial_status & SW_Stack_Fault ) printk("SW: stack fault\n");
> -if ( partial_status & SW_Precision ) printk("SW: loss of precision\n");
> -if ( partial_status & SW_Underflow ) printk("SW: underflow\n");
> -if ( partial_status & SW_Overflow ) printk("SW: overflow\n");
> -if ( partial_status & SW_Zero_Div ) printk("SW: divide by zero\n");
> -if ( partial_status & SW_Denorm_Op ) printk("SW: denormalized operand\n");
> -if ( partial_status & SW_Invalid ) printk("SW: invalid operation\n");

> +if ( partial_status & SW_Backward )
> +printk("SW: backward compatibility\n");
> +if ( partial_status & SW_C3 )
> +printk("SW: condition bit 3\n");
> +if ( partial_status & SW_C2 )
> +printk("SW: condition bit 2\n");
> +if ( partial_status & SW_C1 )
> +printk("SW: condition bit 1\n");
> +if ( partial_status & SW_C0 )
> +printk("SW: condition bit 0\n");
> +if ( partial_status & SW_Summary )
> +printk("SW: exception summary\n");
> +if ( partial_status & SW_Stack_Fault )
> +printk("SW: stack fault\n");
> +if ( partial_status & SW_Precision )
> +printk("SW: loss of precision\n");
> +if ( partial_status & SW_Underflow )
> +printk("SW: underflow\n");
> +if ( partial_status & SW_Overflow )
> +printk("SW: overflow\n");
> +if ( partial_status & SW_Zero_Div )
> +printk("SW: divide by zero\n");
> +if ( partial_status & SW_Denorm_Op )
> +printk("SW: denormalized operand\n");
> +if ( partial_status & SW_Invalid )
> +printk("SW: invalid operation\n");
> #endif /* DEBUGGING */

Well, IMHO, the code was more readable and checkable in the initial
version. I think this is one example of exceptions where code appearance
is more important than style correctness.

Regards,
Willy

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/