Re: [PATCH] lguest: fix mis-merge against hpa's TSS renaming

From: Ingo Molnar
Date: Thu Jan 31 2008 - 04:24:33 EST



* Rusty Russell <rusty@xxxxxxxxxxxxxxx> wrote:

> --- a/drivers/lguest/x86/core.c Thu Jan 31 14:50:43 2008 +1100
> +++ b/drivers/lguest/x86/core.c Thu Jan 31 17:58:44 2008 +1100
> @@ -94,7 +94,7 @@ static void copy_in_guest_info(struct lg
> /* Set up the two "TSS" members which tell the CPU what stack to use
> * for traps which do directly into the Guest (ie. traps at privilege
> * level 1). */
> - pages->state.guest_tss.esp1 = cpu->esp1;
> + pages->state.guest_tss.sp1 = cpu->esp1;

btw., could you perhaps (later on) rename it to ->sp1, so that all the
register namings are consistent in the x86 architecture? Might be handy
for lguest-64 as well :-)

Ingo
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/