Re: [PATCH v2] add time_now_after and other macros which compare with jiffies

From: Dave Young
Date: Sun Mar 09 2008 - 06:44:25 EST


On 3/9/08, Alan Cox <alan@xxxxxxxxxxxxxxxxxxx> wrote:
> > > > +/* time_now_before_eq(a) return true if now (jiffies) is before or equal to a */
> > > > +#define time_now_before_eq(a) time_before_eq(jiffies, a)
> > >
> > > How about even more obvious names like time_is_past(), time_is_future(),
> > > ...?
> >
> > Thanks for comment.
> >
> > Then how do we name the _eq version? IMHO, the time_now_* is enough.
>
>
> Why do you even need them. I don't see the point of *any* of these extra
> macros as they simply obfuscate code and hide what is actually going on.
> The initial macros were added because of the type safety and correct
> comparison rules being complex. They have a purpose.

Yes, This has a purpose as well. You will find most of the usage of these
macros are just compare some value with jiffies after doing some grep.

For these cases this adding will easy use and understand.

>
> Even if you want these you can use !time_future() if you don't want the
> _eq variants. Generally speaking drivers should be using timers not
> polled loops, and most of our loops comparing with jiffies want removing.
>

IMO time_after is a confusing name actually, If I don't read the comment I
will think it as time_future

To some extent I agree with you that the timer will be better.

>
> Alan
>

Thanks
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/