Re: [PATCH 4/5] cdrom: use list_head for cdrom_device_info list

From: Jens Axboe
Date: Sat Mar 22 2008 - 08:56:08 EST


On Sat, Mar 22 2008, Akinobu Mita wrote:
> Use list_head for cdrom_device_info list instead of opencoded
> singly list handling.

Looks good, but you don't seem to be initializing ->list anywhere. Did
you test this?

I'd suggest just adding an INIT_LIST_HEAD() before the list_add() in
register_cdrom()

You also seem to remove the !cdi check, which would be an unrelated
change.

--
Jens Axboe

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/