[PATCH] [POWERPC] i2c: fix build breakage introduced by OF helpers

From: Jochen Friedrich
Date: Fri Apr 18 2008 - 10:23:25 EST


Fix build breakage introduced in commit
"[POWERPC] i2c: OF helpers for the i2c API".
If i2c-core is compiled as module, the helper needs to be
compiled as module, as well. Rename i2c.c to of_i2c.c to
avoid name space conflict.

Signed-off-by: Jochen Friedrich <jochen@xxxxxxxx>
---
drivers/of/Kconfig | 2 +-
drivers/of/Makefile | 2 +-
drivers/of/{i2c.c => of_i2c.c} | 0
3 files changed, 2 insertions(+), 2 deletions(-)
rename drivers/of/{i2c.c => of_i2c.c} (100%)

diff --git a/drivers/of/Kconfig b/drivers/of/Kconfig
index 7c30531..0e39f00 100644
--- a/drivers/of/Kconfig
+++ b/drivers/of/Kconfig
@@ -9,7 +9,7 @@ config OF_GPIO
OpenFirmware GPIO accessors

config OF_I2C
- def_bool y
+ def_tristate I2C
depends on OF && I2C
help
OpenFirmware I2C accessors
diff --git a/drivers/of/Makefile b/drivers/of/Makefile
index a07b953..548772e 100644
--- a/drivers/of/Makefile
+++ b/drivers/of/Makefile
@@ -1,4 +1,4 @@
obj-y = base.o
obj-$(CONFIG_OF_DEVICE) += device.o platform.o
obj-$(CONFIG_OF_GPIO) += gpio.o
-obj-$(CONFIG_OF_I2C) += i2c.o
+obj-$(CONFIG_OF_I2C) += of_i2c.o
diff --git a/drivers/of/i2c.c b/drivers/of/of_i2c.c
similarity index 100%
rename from drivers/of/i2c.c
rename to drivers/of/of_i2c.c
--
1.5.5

--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/