Re: [PATCH 1/4] Add a basic debugging framework for memoryinitialisation

From: Andrew Morton
Date: Sat Apr 26 2008 - 02:12:55 EST


> On Tue, 22 Apr 2008 19:31:53 +0100 (IST) Mel Gorman <mel@xxxxxxxxx> wrote:
>
> This patch creates a new file mm/mm_init.c which is conditionally compiled
> to have almost all of the debugging and verification code to avoid further
> polluting page_alloc.c. Ideally other mm initialisation code will be moved
> here over time and the file partially compiled depending on Kconfig.

I was wondering why the file was misnamed ;)

I worry that

a) MM developers will forget to turn on the debug option (ask me about
this) and the code in mm_init.c will break and

b) The mm_init.c code is broken (or will break) on some architecture(s)
and people who run that arch won't turn on the debug option either.

So hm. I think that we should be more inclined to at least compile the
code even if we don't run it. To catch compile-time breakage.

And it would be good if we could have a super-quick version of the checks
just so that more people at least partially run them. Or something.
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/